GSM-Forum  

Welcome to the GSM-Forum forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features.
Only registered members may post questions, contact other members or search our database of over 8 million posts.

Registration is fast, simple and absolutely free so please - Click to REGISTER!

If you have any problems with the registration process or your account login, please contact contact us .

Go Back   GSM-Forum > Product Support Sections > Hard/Software Products (official support) > Saras Boxes > HWK

Reply
 
LinkBack Thread Tools Display Modes
Old 12-06-2006, 07:46   #1 (permalink)
Junior Member
 
Join Date: Nov 2005
Posts: 31
Member: 199842
Status: Offline
Thanks Meter: 3
HWK UFS 3.03 BB5 Problem

I am running the latest UFS suite 3.03 with Original HWK.... No HWKTools/Killer is installed.
everything is running sweet bar BB5. Check,info/Flash etc.. never works
1st Boot Err:

Is there a good way to restore original unpatched firmware cause it sounds like the Twister box is still patched.....
Cheers
ICUMobile
  Reply With Quote
The Following 2 Users Say Thank You to Icumobile For This Useful Post:
Old 12-06-2006, 09:55   #2 (permalink)
Cheater -Don't Deal with him-
 
.:GSM International:.'s Avatar
 
Join Date: Jan 2002
Age: 39
Posts: 4,789
Member: 8879
Status: Offline
Sonork: 100.84016
Thanks Meter: 327
Quote:
Originally Posted by Icumobile View Post
I am running the latest UFS suite 3.03 with Original HWK.... No HWKTools/Killer is installed.
everything is running sweet bar BB5. Check,info/Flash etc.. never works
1st Boot Err:

Is there a good way to restore original unpatched firmware cause it sounds like the Twister box is still patched.....
Cheers
ICUMobile

Yes mate, you need to format your machine!
  Reply With Quote
The Following User Says Thank You to .:GSM International:. For This Useful Post:
Old 12-06-2006, 09:58   #3 (permalink)
Junior Member
 
Join Date: Nov 2005
Posts: 31
Member: 199842
Status: Offline
Thanks Meter: 3
Thanks for the reply dude ... i will blank my drive completely and do a re-install then install it blank and patch free and report my feedback
  Reply With Quote
Old 12-06-2006, 10:03   #4 (permalink)
Cheater -Don't Deal with him-
 
.:GSM International:.'s Avatar
 
Join Date: Jan 2002
Age: 39
Posts: 4,789
Member: 8879
Status: Offline
Sonork: 100.84016
Thanks Meter: 327
Quote:
Originally Posted by Icumobile View Post
Thanks for the reply dude ... i will blank my drive completely and do a re-install then install it blank and patch free and report my feedback

Ok mate,

keep us posted!
  Reply With Quote
Old 12-06-2006, 11:18   #5 (permalink)
Product Manager
 
karwos's Avatar
 
Join Date: Feb 2005
Location: Poland
Age: 24
Posts: 4,948
Member: 117496
Status: Offline
Sonork: 100.83919
Thanks Meter: 22,699
No need to format Your PC.
Just remove old UFS drivers from Device Manager and install latest ones from c:\program files\sarassoft\ufs_usb_drivers

and after running ufs_dctxbb5 you must see:
(...)
Versions: Ufs2xx.dll 3.1.7, Ufs2xx.sys 2.0.0
(...)

if with following drivers you will still encounter "blank" problem, this is 100% HWK authenthication problem (broken UFS - i encountered such problem on latest batch of NBOX, or HWK itself)

BR
  Reply With Quote
Old 12-06-2006, 11:48   #6 (permalink)
No Life Poster
 
Ramzan's Avatar
 
Join Date: Oct 2004
Location: AL-SATWA DUBAI U.A.E
Age: 36
Posts: 1,235
Member: 86597
Status: Offline
Sonork: 100.1602630
Thanks Meter: 1,069
I am running the latest UFS suite 3.03 with kalon HWK.... No HWKTools/Killer is installed.
everything is running sweet bar BB5. Check,info/Flash etc.. never works
1st Boot Err:
  Reply With Quote
Old 12-06-2006, 11:52   #7 (permalink)
No Life Poster
 
Gr8SightMan's Avatar
 
Join Date: Jul 2005
Posts: 526
Member: 163076
Status: Offline
Thanks Meter: 97
Quote:
Originally Posted by karwos View Post
No need to format Your PC.
Just remove old UFS drivers from Device Manager and install latest ones from c:\program files\sarassoft\ufs_usb_drivers

and after running ufs_dctxbb5 you must see:
(...)
Versions: Ufs2xx.dll 3.1.7, Ufs2xx.sys 2.0.0
(...)

if with following drivers you will still encounter "blank" problem, this is 100% HWK authenthication problem (broken UFS - i encountered such problem on latest batch of NBOX, or HWK itself)

BR
correct but latest ver has bugs in BB5 flashing...
  Reply With Quote
Old 12-06-2006, 11:59   #8 (permalink)
No Life Poster
 
Lhick's Avatar
 
Join Date: Aug 2006
Location: InsideOut
Posts: 5,664
Member: 333359
Status: Offline
Thanks Meter: 90
I installed 3.03 then 3.03 its OK, sometime when I connect It dont work so I just try try to connect or restart PC, or I Reinstall UFS it doesnt bother me at all.
  Reply With Quote
Old 12-06-2006, 14:00   #9 (permalink)
Product Manager
 
Odia The Ultimate's Avatar
 
Join Date: Apr 2001
Location: Where dreams become reality.
Age: 44
Posts: 5,610
Member: 4042
Status: Offline
Thanks Meter: 23,675
Quote:
Originally Posted by Icumobile View Post
I am running the latest UFS suite 3.03 with Original HWK.... No HWKTools/Killer is installed.
everything is running sweet bar BB5. Check,info/Flash etc.. never works
1st Boot Err:

Is there a good way to restore original unpatched firmware cause it sounds like the Twister box is still patched.....
Cheers
ICUMobile
First Boot Error, can be 1 of 3 things:-

1. Your cable
2. The USB drivers are mixed, e.g. sys and dll are not syncronised.
3. The UFS box firmware is old.

Something to note on point 3, if you fuk around with 3rd party tools and all seems ok, its not, none of the 3rd party tools will restore your firmware to the latest version, the firmware has an hidden sub-version which cannot be seen from the boot string, on from this the latest versions of the software will not update the firmware to latest, so again the moral is use 3rd party software at your own risk!!!

How to know you are affected by this?

1. Nokia BB5 will not flash
2. Samsung Swift will not flash
3. KZF will not connect to the phone

Odia.
  Reply With Quote
Old 12-06-2006, 14:15   #10 (permalink)
No Life Poster
 
zigma300's Avatar
 
Join Date: Aug 2005
Age: 41
Posts: 566
Member: 175822
Status: Offline
Thanks Meter: 4
Mr. Odia
i think i am affected by this i think it is a firmware issue please what can be done to fix it. i don´t want to mess with 3rd party proggies as i have both UFS and HWK are original. KZF is the problem.
3. KZF will not connect to the phone.
it is important as i enjoy using UFS3 and HWK although i have alot of other stuff but still i have the passion for this box is there a way to restore firmware in anyway and generate original strings
  Reply With Quote
Old 12-06-2006, 18:39   #11 (permalink)
Product Supporter
 
trashed's Avatar
 
Join Date: Jan 2002
Location: Philippines
Posts: 491
Member: 8303
Status: Offline
Thanks Meter: 110
hi,

at Odia's post. in #3 - it can be easily fix

the trick is you have to use all version of UFS_SUITE from OLD to NEW

like what Odia have said, every release, SARAS update the box secretly thats why, everytime you try to flash BB5, you will notice RX and TX leds flashing and it takes time before it connects to phone, reason is the software is reprogramming/updating your box. i've experienced it before and found a very easy solution

procedure is at your own risk cause it will use third party software and you'll be needing a TRIAL HWK cause ORIGINAL HWK are probably been UPDATED and can't be detected by older version of UFS_SUITE which is needed.

1. remove your ORIGINAL HWK
2. downgrade your box using UNISOFT's software to 2.5
3. use version 1.3k to update your box to 2.6
4. use TRIAL HWK (the one with A1.02 firmware) and use old version of UFS_HWK_Suite (1.4a). go to BB5 tab and press "CHECK" the software will reprogram your box. (you can do this even theres no connected phone)
5. repeat step 4 but use the next updated version of SUITE (1.4b until 1.4f)
6. remove TRIAL HWK and put your ORIGINAL HWK
7. repeat step 4 using version 2.0 then 2.01 and so on...
8. enjoy flashing BB5 with your fixed box

note. using trial is necessary cause if you own original HWK, it should be updated and old UFS version doesnt recognise new HWK firmware. but it doenst mean we must support clones, its just my way of repairing my box having this error before. hope my procedure helps.
  Reply With Quote
The Following User Says Thank You to trashed For This Useful Post:
Old 12-07-2006, 02:55   #12 (permalink)
Product Manager
 
Odia The Ultimate's Avatar
 
Join Date: Apr 2001
Location: Where dreams become reality.
Age: 44
Posts: 5,610
Member: 4042
Status: Offline
Thanks Meter: 23,675
Quote:
Originally Posted by zigma300 View Post
Mr. Odia
i think i am affected by this i think it is a firmware issue please what can be done to fix it. i donīt want to mess with 3rd party proggies as i have both UFS and HWK are original. KZF is the problem.
We will add a check and repair routine to the update client next release, since both the UFS and HWK firmware will be changing.

Odia.
  Reply With Quote
Old 12-07-2006, 09:34   #13 (permalink)
No Life Poster
 
zigma300's Avatar
 
Join Date: Aug 2005
Age: 41
Posts: 566
Member: 175822
Status: Offline
Thanks Meter: 4
amazing gr8 news Mr.Odia i am waiting for that repair.
  Reply With Quote
Old 12-07-2006, 10:58   #14 (permalink)
Junior Member
 
Join Date: Nov 2005
Posts: 31
Member: 199842
Status: Offline
Thanks Meter: 3
Thanks for all the replies...

I got BB5 flashing to work but downgrading the firmware to 2.5 and ran the latest 2.03 software and it upgraded my box to 2.6.. And since then all bb5 flashing has been fine

Keep the feedback going for this topic because it seems to help out a lot of people...

Cheers
Icumobile
  Reply With Quote
Old 12-07-2006, 16:48   #15 (permalink)
Junior Member
 
Join Date: Dec 2006
Location: belgium
Posts: 20
Member: 404984
Status: Offline
Thanks Meter: 0
hello
my ufs + HWK
was downgrading with the software DCTxBB5 Tools V2.03 HWK
to Ufs2_v25.fbi ( 8,192bytes )

and now i can't connect to my software
the message is

UFxBoot V2.2 (c) SarasSoft 2003. Id: 62 CF 0 0
UFS_USB V2.5 (c) SarasSoft 2003. S/n: 73173
Update Init Fail !

and when i try the software HWK Update client v2.03
the message is

Error connecting UFS:
HWK LOGIN ERROR: -3

thank you for you understand
  Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
thread Thread Starter Forum Replies Last Post
Need ufs 3.03 setup S.Leo UFS2 + UFS3-Tornadoflasher 6 08-04-2008 10:39
need ufs 3.03 suite HUM HWK 8 01-06-2007 07:32
C1100 doesn't boot with UFS 3.03 Benkophone LG 0 11-07-2006 18:08
hwk ufs 3 ufs 4 modul hwk helpp raskal ceptel Twisterflasher 0 05-28-2006 17:17

 



All times are GMT +1. The time now is 20:50.



Powered by Searchlight © 2014 Axivo Inc.
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
- GSM Hosting Ltd. - 1999-2014 -
Page generated in 0.44803 seconds with 8 queries

Content Relevant URLs by vBSEO